Системные требования Joomla 3, Joomla 2.5, Joomla 1.5 и других версий / О Joomla! CMS .:. Документация Joomla! CMS

Опубликовано: 10.04.2018

видео Системные требования Joomla 3, Joomla 2.5, Joomla 1.5 и других версий / О Joomla! CMS .:. Документация Joomla! CMS

1 Преимущества связки Gantry 5 и Joomla Шаблоны трансформеры во всей красе


2 Установка Gantry 5 Документация и системные требования

Требования для Joomla 3.x

Программное обеспечение Рекомендуемая версия Минимальная версия
PHP (Magic Quotes GPC off) 5.3.1 + 5.3.1 +
Поддержка баз данных:
MySQL (InnoDB support required) 5.1 + 5.1 +
MSSQL 10.50.1600.1+ 10.50.1600.1+
PostgreSQL 8.3.18 + 8.3.18 +
Поддержка Web-сервера:
Apache


Введение в JBZoo

(с mod_mysql, mod_xml,

и mod_zlib)
2.x + 2.x +
Nginx 1.1 1.0
Microsoft IIS 7 7

Требования для Joomla 2.5.x, 1.7.x and 1.6.x

Программное обеспечение Рекомендуемая версия Минимальная версия
PHP 5.3 + 5.2.4 +
MySQL 5.0.4 + 5.0.4 +
Поддержка Web-сервера:
Apache

(с mod_mysql, mod_xml,

и mod_zlib)
2.x + 2.x +
Nginx 1.1 1.0
Microsoft IIS 7 7

Требования для Joomla 1.5.x

Программное обеспечение Рекомендуемая версия Минимальная версия
PHP* 5.2 + 4.3.10
MySQL** 4.1.x + 3.23
Поддержка Web-сервера:
Apache***

(with mod_mysql, mod_xml,

and mod_zlib)
2.x + 1.3
Microsoft IIS**** 7 6

Requirements for Joomla 1.0.x

Программное обеспечение Рекомендуемая версия Минимальная версия
PHP* 5.2 + 4.2
MySQL** 4.1.x + 3.23
Поддержка Web-сервера:
Apache***

(с mod_mysql, mod_xml,

и mod_zlib)
2.x + 1.3
Microsoft IIS**** 7 6

* Не используйте PHP 4.3.9, 4.4.2 или 5.0.4. Эти релизы имеют баги, которые будут конфликтовать с установкой Joomla. Zend Optimizer 2.5.10 для PHP 2.4.x также имеет несколько багов и вы должны обратиться к вашему провайдеру для того, чтобы его обновить. Joomla 1.5.15+ совместима с PHP 5.3. Заметьте, что библиотека OpenID не совместима на PHP 5.3

** Joomla не совместима с MySQL 6.x

*** Для того, чтобы использовать  SEO URL , у вас должно быть установлено расширение Apache mod_rewrite

*** Для Microsoft IIS, в зависимости от вашей установки, необходимо следующее:

PHP 5.2 MySQL 5.1 Microsoft URL Rewrite Module - требуется только для SEO URL-ов. FastCGI.

Joomla была успешно опробована на различных вариантах основных операционнах систем, таких как Windows, Linux, Apple Mac OS. Она может также работать на других платформах, но это уже будет менее документированная поддержка - "на свой страх и риск".

Joomla также регулярно используются и тестируется среди основных наиболее популярных веб-браузеров, таких как IE6 +, Firefox 1.5 +, Safari и Opera.

Следует иметь ввиду что у IE6 есть проблемы с отображением стилей  CSS , поэтому рекомендуем использовать более современные браузеры.